Jump to content
PDS Geosciences Node Community
Ralph Vidal

CRISM : CAT map projection

Recommended Posts

Hi guys,

I am using the CAT tool (latest version, 4/8/20)  to map project crism data,  I am not getting it right,   when I overlay the projected data on a CTX image  they do not quite fit.  When projecting  the crism tr3 image using CAT I get  error message shown in the first picture.

The CAT instruction  at  https://astropedia.astrogeology.usgs.gov/download/Docs/PlanetaryDataWorkshop/Presentations2017/Monday/Humphreys/Morgan_CATupdates.pdf  tells that "

Quote

Custom spheres, datum, and reference system definitions must be correctly installed

  Where do I get those definitions ?  Is there some .proj  file I have to put into the envi folder/ CAT folder ?

 The third picture shows the swipe made with a crism image overlain on the CTX image. Latitude seems to fit, longitude does not..

Thanks

Ralph

projection_error.JPG

map__instructions.JPG

swipe.png

Share this post


Link to post
Share on other sites

Hi Ralph,

This is Feng. I will assistant you on this issue.These definitions are in CAT folder: CAT_ENVI -> aux_files -> crism_projection. These are three files in the folder. And you shall copy them to ENVI folder like:

C:\Program Files\Harris\ENVI55\IDL87\resource\pedata\user_defined

You can check CAT installation guide for more details: step 5 in https://pds-geosciences.wustl.edu/missions/mro/CAT_74_ENVI_5x_Setup_Windows.pdf

 

Please let me know if you have any question.

 

Thanks,

 

Feng

 

image.png.d1bc940361aedd3813d9eca583615cba.png

Share this post


Link to post
Share on other sites

Hi Feng,

thanks, I copied the files to the envi directory.  The error message is gone.      Anyway  the images still do not fit.

1) CTX image:   

   
Data http://murray-lab.caltech.edu/CTX/tiles/beta01/E-024/Murray-Lab_CTX-Mosaic_beta01_E-024_N20_data.zip
Thumbnail        http://murray-lab.caltech.edu/CTX/tiles/beta01/E-024/Murray-Lab_CTX-Mosaic_beta01_E-024_N20_thumb.png

 

2) CRISM image ( unprojected) :       frt0000a5aa_07_if166l_trr3

  http://themis-data.asu.edu/viewer/crism#P=FRT0000A5AA_07_IF166L_TRR3&T=2           ( all links  to download to ddr1 and img files on the page )

 

Could the problem lie with the CTX image projection settings ?   

Thanks

Ralph

 

envi.JPG

Share this post


Link to post
Share on other sites

Hi Ralph,

i saw the miss-match feature when overlapping CRISM on CTX even projecting them to the same map projection. This is because CTX and CRISM are from two instruments and processed differently. So you may use ENVI image registration to co-register CRISM to CTX to reduce the difference (see image registration workflow in ENVI: https://www.harrisgeospatial.com/docs/ImageRegistration.html). Please let me know if you have any question.

Thanks,

Feng

Share this post


Link to post
Share on other sites

Hi Feng,

the geo-referencing  works now , I did the  images co-registering  as you explained.         The reprojected image is on the right place,   but it seems to  have an issue with the bands :    usually the false color RGB should be  bands 199, 354 and 419.    It shows strange results though ( image is red ,see pics )

thanks 

Ralph

before_warp.JPG

after_warp_only_red.JPG

Share this post


Link to post
Share on other sites

Hi Ralph,

This is caused by ENVI displaying the CRISM 65535 data_ignore_value. The warp image is displaying the big span than the valid data range. To display it correctly, you can modify the histogram stretch. Here are the steps:

1, first check the histogram for three bands value range of the trr3:

image.png.164b107b2104a228a728c1d59ca44b4b.png

2, use "save as" tool under File to output the warped result to specify the data ignore value:

image.png.f447e0ac44ffd0f627276e29a7d6194b.png

image.png.018009b592a584b7812d99752a397f2a.png

3, then change the output image accordingly:

From

image.thumb.png.a857bded731e5172b39fb12e766651ff.png

to:

image.thumb.png.4c3c9b0bf3b2cae9e1063d0e81df8e02.png

Please let me know if you have any questions.

Thanks,

Feng

 

Share this post


Link to post
Share on other sites

hi Feng,

I managed to correct the image as you explained.  But when I set the ignore value to  65535 it seems to keep a black stripe on one side that I cannot get rid of ( see attachments ) .  When I set the ignore value to 0,  the black stripe disappears but a white background appears.  There is some kind of white line around the picture too.  Do you maybe have any hints how to fix this ?

Thanks 

Ralph

 

black_stripe_on_imageJPG.JPG

white_background.JPG

Share this post


Link to post
Share on other sites

Hi Ralph,

I checked the same frame I processed two weeks ago. It seems I don't have the black strip.

What is the value at the black strip when you move mouse on the black strip using cursor value in ENVI? How big is the result file?  Would you please resample it to small one and then send it to me with the header file?

Thanks,

Feng

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...