Jump to content
PDS Geosciences Node Community

OLINDEX, LCPINDEX, HCPINDEX (RGB) image inaccuracy in CAT


cmckinla
 Share

Recommended Posts

Hello,

 

I am having an issue  getting my RBG images to look similar to the IR derived product (ID: 0000CE1D)  which shows Mafic minerology from the CRISM data products page. I have converted the image from pds to CAT, performed a photometric correction and performed a volcano scan. Once these corrections were made I created my summary products for the corrected image. I have loaded OLINDEX into the red, LCPINDEX into the green and HCPINDEX into the blue. Areas which have shown up dark purplish blue in the IR derived products page for mafic minerology represent high -Ca pyroxene. However, these areas show up as a bright greenish cyan colour which resembles more of a low-Ca pyroxene when I load in the summary parameters myself. 

 

Any insight/assistance would be much appreciated!

 

Regards,

 

Colin 

Link to comment
Share on other sites

It sounds to me like the problem is stretch limits. For the IR derived products, there are standard stretch limits applied that are described in the informational pages about browse products. However ENVI typically applies autostretches (min to max with tails cut off) that distort the colors compared to what you would find in the derived IR products generated by the CRISM team.

Link to comment
Share on other sites

Here's how you can reproduce the published browse image.

 

First, get some info about the published browse image. If you're looking at the products on crism-map.jhuapl.edu, click on the "Map/Stretch info" link in the box with the ir_maf thumbnail image. Note the ranges on the RGB channels (0-0.13, 0-0.1, 0-0.2)

 

Now in ENVI with CE1D, do what you did, which produces the autoscaled display with the bright colors.

 

Then from the display window with that image, go to Enhance/Interactive Stretching...

 

A window pops up; note the R-G-B radio buttons; R should be selected initially, that's fine, now go to the "Options" menu, click "Histogram Parameters" and enter the Red channel min and max (0 and 0.13 from the map/stretch info data you looked at before) in the Histogram Min and Histogram Max boxes, and click "Apply." Now go back to the Histogram Stretching window and select the "G" radio button, then go back to the parameter box, enter the G channel min (0)  and max (0.1), and click apply. Now repeat for blue. When you're all done, close the little histogram parameter box. Then finally click "Apply" in the Interactive Strecting window, and the display colors should restretch to match the published image.

 

Maybe there's an easier way - but that's the procedure I know.

Frank

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...